1c8 как добавить или прочитать дополнительный реквизит

Передо мной стояла задача сделать культурное заполнение дополнительных реквизитов типа строка кодами номенклатуры через разделитель.

Прочитать значения дополнительных реквизитов

 Для каждого ДопРеквизит Из Номенклатура.ДополнительныеРеквизиты Цикл
		Если ДопРеквизит.Свойство.Наименование = НазваниеДопРеквизита  Тогда
			Значение = ДопРеквизит.Значение;
		КонецЕсли; 		
КонецЦикла;

Добавить значение в дополнительный реквизит

СвойствоРеквизита = ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("Аналоги");	
НовыйРеквизит			= ТекущийОбъект.ДополнительныеРеквизиты.Добавить();
НовыйРеквизит.Свойство 	= СвойствоРеквизита;
Для Каждого Строка Из ТекущийОбъект.Аналоги Цикл 
Аналоги = Строка(Аналоги) + "/" + Строка(Строка.Номенклатура.Код);
КонецЦикла;
НовыйРеквизит.Значение = Аналоги;


Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *