1с8.2 получить выделенные строки из динамического списка

Кто пробовал получить данные с динамического списка меня поймет — это большой геморой. Для себя я нашел два пути решения первый  — это выгребать данные через выделенные строки (самый простой), второй — создать  аналогичный динамическому списку запрос  и в него указать параметры отбора указанные пользователем, но это не работает если пользователь решит фильтрануть пользуясь поиском.

Итак первый вариант получение данных через выделенные строки.

&НаКлиенте

Процедура ПолучателиВыбор(Элемент, ВыбраннаяСтрока, Поле, СтандартнаяОбработка)
СтандартнаяОбработка = Ложь;
Телефон = ПолучитьТелефон(ВыбраннаяСтрока);
Структура = Новый Структура("Объект, Поле1, Поле2, Поле3", Телефон.Наименование, Телефон.НомерТелефона, "", "");
// "эмулируем" выбор из "Контактной информации"
ОповеститьОВыборе(Структура);

КонецПроцедуры

&НаКлиенте
Процедура Заполнить(Команда)
ВыделСтроки = ОтобратьПоОтбору ();
Если НЕ ВыделСтроки = Неопределено Тогда
Для Каждого Строка Из ВыделСтроки Цикл
//Структура = Новый Структура("Объект, Поле1, Поле2, Поле3", Строка.Наименование, Строка.НомерТелефона, "", "");
Сообщить(Строка);
КонецЦикла;
КонецЕсли;
КонецПроцедуры

Продолжение следует….

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *