1с8 Установить отбор в форме выбора (Управляемое приложение)

Устанавливаем отбор по двум полям операция и валюта.

&НаКлиенте
Процедура ПриОткрытии(Отказ)
ЭлементОтбора = Список.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
ЭлементОтбора.ЛевоеЗначение = Новый ПолеКомпоновкиДанных("Валюта");
ЭлементОтбора.ВидСравнения =  ВидСравненияКомпоновкиДанных.Равно;
ЭлементОтбора.Использование = Истина;
ЭлементОтбора.ПравоеЗначение = ПолучитьВалюту ();

ЭлементОтбора = Список.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
ЭлементОтбора.ЛевоеЗначение = Новый ПолеКомпоновкиДанных("ХозяйственнаяОперация");
ЭлементОтбора.ВидСравнения =  ВидСравненияКомпоновкиДанных.Равно;
ЭлементОтбора.Использование = Истина;
ЭлементОтбора.ПравоеЗначение = ПолучитьОперацию ();

КонецПроцедуры

&НаСервере
Функция ПолучитьВалюту ()
Возврат Справочники.Валюты.НайтиПоКоду("643");	
КонецФункции

&НаСервере
Функция ПолучитьОперацию ()
Возврат Перечисления.ХозяйственныеОперации.КонвертацияВалюты;	
КонецФункции

1с8 Установить отбор в форме выбора (Управляемое приложение): 1 комментарий

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *