Как в 1с8 программно проверить доступность роли пользователю?

Если Не РольДоступна("Продавец") Тогда
Сообщить("Доступ запрещен!");
КонецЕсли;
Функция СписокВозможныхРолейКонфигурации()
СписокРолей = новый СписокЗначений;
РолиКонфигурации = Метаданные.Роли;
Для каждого Роль из РолиКонфигурации Цикл
СписокРолей.Добавить(Роль.Имя);
КонецЦикла;
Возврат СписокРолей;
КонецФункции

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *