1С 8 Функции для вызова диалога ввода данных в системе

Очень часто приходится использовать формы для ввода данных, стандартные функции экономят время и помогают не нагружать конфигурацию.

ВвестиДату (InputDate)

Синтаксис:

ВвестиДату(,,)

Параметры:

Обязательный

Тип: Дата. Имя доступной в модуле переменной. В эту переменную будет помещено введенное значение даты. Начальное значение переменной будет использовано в качестве начального значения в диалоге.

Необязательный

Тип: Строка. Текст заголовка окна диалога ввода даты. Может использоваться в качестве подсказки пользователю.

Значение по умолчанию: Пустая строка.

Необязательный

Тип: ЧастиДаты. Вводимая в диалоге часть (или части) даты. Значение по умолчанию: ДатаВремя.

При определении значения параметра используется системное перечисление ЧастиДаты (DateFractions) . Перечисление содержит следующие значения:

Время (Time) — Значение состоит только из времени (без даты).
Дата (Date) — Значение состоит только из даты (без времени).
ДатаВремя (DateTime) — Значение состоит из даты и времени.

Возвращаемое значение:

Тип: Булево. Истина — дата введена. Ложь — пользователь отказался от ввода даты.

Описание:

Вызывает диалог для ввода даты.

Пример:

ДатаНапоминания = РабочаяДата;
Подсказка = «Введите дату и время»;
ЧастьДаты = ЧастиДаты.ДатаВремя;
Если ВвестиДату(ДатаНапоминания, Подсказка, ЧастьДаты) Тогда
// запомнить дату напоминания
КонецЕсли ;

ВвестиЗначение (InputValue)

Синтаксис:

ВвестиЗначение(< Значение>,,)

Параметры:

Обязательный

Тип: Произвольный. Имя доступной в модуле переменной. В эту переменную будет помещено введенное значение. Если параметр Тип не задан или имеет пустое значение, тип данной переменной используется в качестве типа вводимого в диалоге данного. Начальное значение переменной будет использовано в качестве начального значения в диалоге.

Необязательный

Тип: Строка. Текст заголовка окна диалога ввода значения. Может использоваться в качестве подсказки пользователю.

Значение по умолчанию: Пустая строка

Необязательный

Тип: Тип, ОписаниеТипов. Тип вводимого значения.

Значение по умолчанию: Если параметр не указан, используется тип параметра

Возвращаемое значение:

Тип: Булево. Истина — в диалоге было введено значение, Ложь — пользователь отказался от ввода значения.

Описание:

Вызывает диалог для ввода значения заданного типа.

Пример:

ВыбЗнач = «» ;
М = Новый Массив;
М.Добавить(Тип(«Число»));
М.Добавить(Тип(«Строка»));
М.Добавить(Тип(«Дата»));
КЧ = Новый КвалификаторыЧисла(12,2);
КС = Новый КвалификаторыСтроки(20);
КД = Новый КвалификаторыДаты(ЧастиДаты.Дата);
ОписаниеТипов = Новый ОписаниеТипов (М,КЧ, КС, КД);
Если ВвестиЗначение(ВыбЗнач, «Введите значение», ОписаниеТипов) Тогда
// обработка введенного значения
КонецЕсли;

ВвестиСтроку (InputString)

Синтаксис:

ВвестиСтроку(< Строка>,,,}

Параметры:

Обязательный

Имя доступной в модуле переменной. В эту переменную будет помещена введенная в диалоге строка. Начальное значение переменной будет использовано в качестве начального значения в диалоге.

Необязательный

Тип: Строка. Текст заголовка окна диалога ввода строки. Может использоваться в качестве подсказки пользователю.

Значение по умолчанию: Пустая строка.

Необязательный

Тип: Число. Длина вводимой строки.

Значение по умолчанию: Если параметр не указан или 0 — строка неограниченной длины.

Необязательный

Тип: Булево. Признак ввода многострочного текста: Истина -ввод многострочного текста с разделителями строк, Ложь -ввод простой строки.

Значение по умолчанию: Ложь.

Возвращаемое значение:

Тип: Булево. Истина — строка введена. Ложь — пользователь отказался от ввода строки.

Описание:

Вызывает диалог для ввода строки.

Пример:

Текст = «»;
Подсказка = «Введите текст напоминания»;
Если ВвестиСтроку (Текст,Подсказка, 0, истина) Тогда
// запомнить текст напоминания
КонецЕсли;

ВвестиЧисло (InputNumeric)

Синтаксис:

ВвестиЧисло(< Число,,,)

Параметры:

< Число> Обязательный

Тип: Число. Имя доступной в модуле переменной. В эту переменную будет помещено введенное число. Начальное значение переменной будет использовано в качестве начального значения в диалоге.

Необязательный

Тип: Строка. Текст заголовка окна диалога ввода числа. Может использоваться в качестве подсказки пользователю.

Значение по умолчанию: Пустая строка.

Необязательный

Тип: Число. Длина вводимого числа включая дробную часть (символы разделителей не учитываются).

Значение по умолчанию: 0.

Необязательный

Тип: Число. Количество знаков в дробной части вводимого числа.

Значение по умолчанию: 0.

Возвращаемое значение:

Тип: Булево. Истина — число введено, Ложь — пользователь отказался от ввода.

Описание:

Вызывает диалог для ввода числа.

Пример:

КолВо = 1;
Если ВвестиЧисло(КолВо, «Введите количество», 10, 2) Tогда
// обработка введенного количество
КонецЕсли;

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *